fredag 11th juli 2025

Brevo E-Mail delivery paused

We are currently experiencing problems in the email delivery from our applications, when using the our default mail delivery service. Mails are getting queued and will be delivered with a delay, when the incident is resolved.

Update 12:40: Our service provider is already working on fixing the mail delivery.

Update 13:30: The email delivery works as expected again. All queued emails should have been transferred now.